Depot - Issues starting container builds for public repo PRs – Incident details

Issues starting container builds for public repo PRs

Resolved
Partial outage
Started 7 months agoLasted 6 minutes

Affected

Container builds

Major outage from 4:39 PM to 4:45 PM

us-east-1

Major outage from 4:39 PM to 4:45 PM

eu-central-1

Major outage from 4:39 PM to 4:45 PM

us-west-2

Major outage from 4:39 PM to 4:45 PM

GitHub Actions

Operational from 4:39 PM to 4:45 PM

Depot-managed Actions Runners

Operational from 4:39 PM to 4:45 PM

Updates
  • Resolved
    Resolved

    The authentication failure was caused by an expired OIDC signing certificate that has been renewed. We have deployed a fix to prevent this in the future. All builds are operational.

  • Investigating
    Investigating
    We are currently investigating authentication failures for `depot build` commands running in `pull_request` CI jobs from public repos / forks.