Depot - Longer GitHub Actions queue times – Incident details

Longer GitHub Actions queue times

Resolved
Degraded performance
Started 4 days agoLasted about 1 hour

Affected

Container builds

Operational from 4:28 PM to 5:41 PM

us-east-1

Operational from 4:28 PM to 5:41 PM

eu-central-1

Operational from 4:28 PM to 5:41 PM

GitHub Actions

Operational from 4:28 PM to 5:41 PM

Depot-managed Actions Runners

Operational from 4:28 PM to 5:41 PM

Github.com - Actions

Updates
  • Resolved
    Resolved

    We are observing queue times returning to normal. We will continue to monitor.

  • Update
    Update

    We are continuing to see recovery but are continuing to monitor the remaining outliers.

  • Monitoring
    Monitoring

    We have deployed a fix and are monitoring for queue time recovery.

  • Identified
    Identified

    We've discovered a failure in our task scheduler that is blocking operations. We're deploying a fix that should unblock jobs.

  • Investigating
    Investigating

    We are currently investigating possible delays in Actions jobs starting.